🇺🇸 AMBOSS Web platform is partially not working as expected
Incident Report for AMBOSS
Resolved
This incident has been resolved.
Posted Oct 15, 2024 - 11:44 UTC
Investigating
We are currently investigating this issue.
Posted Oct 15, 2024 - 11:08 UTC
This incident affected: 🇺🇸 AMBOSS Web.