🇺🇸  AMBOSS Web Assignments, Qbank Sessions, and Study Plans are missing

Incident Report for AMBOSS

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 22:23 UTC

Update

Some of our US systems that involve the Assignments, Qbank Sessions, and Study plans are affected. We are currently investigating the issue.
Posted Oct 28, 2025 - 20:45 UTC

Investigating

Some of our US systems that involve the Assignments, Qbank Sessions, and Study plans are affected. We are currently investigating the issue.
Posted Oct 28, 2025 - 20:29 UTC
This incident affected: 🇺🇸 AMBOSS Web.